Back to Main Page

<br>

Introduction

This page demonstrates how to setup the Alpha code base for use. Currently this page contains instructions for only the NetBeans IDE, but instructions for the Eclipse IDE may be added later. If using the Eclipse IDE take a look at Initial Setup 3 as these instructions will get you most of the way through. Note that Maven integration with the NetBeans IDE is significantly easier and more straightforward.

<br>

Get the Code

<br>

Install SVN Client

There are many SVN clients available for use and you are free to use any of your choice. This setup guide will assume the use of TortoiseSVN. Download the client and follow the installation instructions for setup.

<br>

Create a New Folder

none|frame|Create a New Folder

<br>

Create a folder to house the code. This folder can be placed anywhere on your system. To create a new folder, right click and select New → Folder. You may the name the folder whatever you like.

<br>

SVN Checkout

none|frame|Alpha SVN Checkout

<br>

Checkout the code from the repository. To do this right click on the newly created folder and select SVN Checkout.

<br>

none|frame|Checkout the Alpha Code

<br>

This will pop up a window allowing you to choose the location from which to checkout the code. The code is located at http://dithers.cs.byu.edu/degsvn/Alpha. Once the path is correct click OK and the code checkout will begin. This may take a few minutes.

<br>

Put the Code in the IDE

<br>

Download NetBeans

Download the NetBeans IDE and install it on your computer. You only need Java functionality but it doesn't hurt to get the extra features. The installation process may take a few minutes depending on which package you choose to install.

<br>

Install Maven Plugin

none|frame|Install the Maven plugin for NetBeans

<br>

Open NetBeans and select the Tools → Plugins menu item. This will bring up a dialog box with numerous options. Select the Available Plugins tab and search for “maven.” This will bring up the “Selenium Module for Maven” plugin that we need. Check the Install check box and click on the install button, accept the license agreement, and unblock NetBeans from accessing the web if necessary.

<br>

Import the Code

Select File → Open Project and browse to the top-level folder of the checked-out code. Note that an icon showing “ma” will appear over the folder indicating that NetBeans recognizes that the folder is a Maven project (much easier than Eclipse). Click on Open Project.

<br>

Build and Execute the Code

The following three steps explain how to build and execute the code.

<br>

Build the Projects

To build the project right click on Alpha, and select “Build.” Ignore the warning message and unselect the check box so that you will not see warning messages in the future. The initial build process will take several minutes as it requires maven to download all of the dependencies for the project.

<br>

Opening Modules

Underneath the Modules folder under Alpha you will notice all of the individual projects. As modules are added to the pom.xml file this file will be refreshed automatically. To work on any project individually you simply double click on a module. This will open the module in the projects tab.

<br>

Executing the Workbench

The workbench code is in the WorkbenchShell module. Open this module, right click on the project, and select “Run.” The main class is edu.byu.deg.workbenchshell.view.WorkbenchShell.java.

<br>

Additional Instructions

Temporarily there are additional steps if you wish to use the Workbench Webbrowser. The instructions for setup are available here.

<br>

Archives

Initial Setup - initial build that caused many headaches <br> Initial Setup 2 - less headaches, but still bad <br> Initial Setup 3 - setup using the Eclipse IDE, somewhat outdated but pretty close <br>

<br>

deg/initial-setup-4.txt · Last modified: 2015/06/12 20:46 by ryancha
Back to top
CC Attribution-Share Alike 4.0 International
chimeric.de = chi`s home Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0