The following instructions on how to setup the CCASH client for development may also be found in the Ccash project under docs/how-to. Edits here should be refelected back to the project.

Install Eclipse and Plugins

Install Eclipse

If Eclipse is not installed on your system, visit the Eclipse Download Page And aquire the proper version of eclipse for you platfrom. The Eclipse IDE for Java EE Developers is the easiest to setup with the other plguins needed for Ccash development, but any should do.

Install Google Plugin

To install Google's web application plugin for eclipse

  1. Open Eclipse and click on Help→Software Updates→Available Software→Add Site
  2. Add the following site: http://dl.google.com/eclipse/plugin/3.4 (for Ganymede) or http://dl.google.com/eclipse/plugin/3.5 (For Galileo)
  3. Install everything in the software repository that appears.

Note: If the google plugin is stalling on install it is likely that eclipse is attempting to search for updates to google's dependencies. You can prevent this by opening ::Help > Software Updates > Available Software > Manage Sites and unchecking everything except the google site above.

Install Mylyn Trac Plugin

To install Mylyn's trac plugin for eclipse

  1. Open Eclipse and click on Help→Software Updates→Available Software→Add Site
  2. Find and install the Trac plugin inside the new Mylyn Extras software repository.

Notes:

  • Sometimes the mylyn extras site is available but not active in eclipse. Go to Help→Software Updates→Available Software→Manage Sites to activate.
  • Depending on which version of Eclipse you use, you may need to install the core components of Mylyn integration as well.
  • Set up your Trac repository
    • Open the “Team Synchronizing” Perspective
    • Right click in Task Repositories, select “Add Task Repository
    • Select the “Trac” option and add the following repository “http://nlp.cs.byu.edu/trac/ccash
    • Fill in your credentials
    • Validate, and finish.
  • :Now you can see and check off tickets in the “Planning” Perspective.
  • Queries are simply ways of filtering the trac tickets and feature
  • :requests for your convenience.

Install Subclipse Plugin

To install the Sublipse subversion plugin for eclipse 3.4

  1. Open Eclipse and click on Help→Software Updates→Available Software→Add Site
  2. Install everything in the resulting software repository.

Notes:

  • Subclipse options show up when you right click on a project or file and select “Team”.
  • When you commit code, remember to write a brief message describing your changes.
  • Please don't check in code that does not compile
  • If you have a working copy and subclipse is not sensing it, try the following:
    • Right click the project,
    • Do Team→Share Project and select SVN.
  • :It should discover your .svn files and repository at this point.

CCASH Eclipse Setup

To setup an Eclipse project for CCASH development:

Setup Project

1. Install Eclipse and several plugins:

 a) The Subclipse plugin (see [[#Install Subclipse Plugin]]).
 b) The Google plugin (see [[#Install Google Plugin]]).
 c) The Trac plugin (see [[#Install Mylyn Trac Plugin]]).

2.Checkout project:

 a)Do File->New->Project
 b)Select SVN->Checkout Projects from SVN
 c)Select "Create a new repository location" and click Next
 d)Enter the repository URL http://nlp.cs.byu.edu/subversion/ccash/trunk
   *If you don't have permission to access the repository,
    speak with an nlp lab sysadmin.
 e)Select the root of the repository and click Next
 f)Select "Check out as a project configured using the New Project Wizard"
 g)click Finish

3.Create Project: :A new window should have opened that appears the same as step 2.b

 a)Select Google->Web Application Project
 b)For the "Project Name" box, enter "Ccash"
 c)For "Package" box, enter "edu.byu.nlp.ccash"
 d)DESELECT "Use Google App Engine" if selected
 e)Click Finish
:Eclipse will now take a while to check out your project. Be patient.

4. Add libraries to the build path:

 a)Right click on your project and select properties.
 b)Do "Java Build Path"->"Libraries"->"Add JARs"
 c)Select all the jars inside your project's war/WEB-INF/lib folder.
 d)Do "Add Library"
 c)Select JUnit and click Next
 d)Select JUnit 3 and click Finish

5. In order to run JUnit tests, you'll need to make the test directory into a src directory on the build path.

 a)Right click on your project
 b)Select "Properties"->"Build Path"->"Source"->"Add Folder"
 c)Select the "test" folder.  

6.Generate Eclipse run configurations for running JUnit tests and creating internationalizable constants by editing and running the script tools/createCcashEclipseTargets.sh (or .bat). Note: This should be run from the root directory of the project.

7.Set up trac repository (See Notes in Install Mylyn Trac Plugin)

8. Set Subplcipse to ignore autogenerated files.

 a)Do  Window->Show View->Navigator
 b)For each file/folder:
   i. Right Click
   ii. Select Team->Add to svn:ignore.
   iii. Click Okay
  Folders:
   .settings
   www-test
   tomcat
  Files:
   .classpath
   .project
   CcashConstants*
   CcashTest*

:Most of these files/folders will have a small ? icon. If they have neither a ? nor a small cylinder then they have already been set to be ignored. :Note:The hibernate.cfg.xml file and the tools/createCcashEclipseTargets ::should only be committed if project wide changes are made so as not ::to interfere with others settings. Upon commit, eclipse will ::give you the option to not commit specific files. In the case of ::createCcashEclipseTargets itmay be easiest to undo your changes after ::running as it will not be needed again.

9. Set up your database (see CCASH Database Setup).

Run in Hosted Mode

Your Ccash client should now be ready to run in hosted mode. Select the root of the project and select “Run”→“Run As”→“Web Application” to have Eclipse generate the default run configuration.

The default login is

 username:admin
 password:passwd

Note For 64-bit users: There are issues with getting hosted mode to run on 64-bit java. Installing different JREs is platform dependant but the one eclipse will use to run your project can be set in Run→Run Configurations.

Deploy to Tomcat Server

To deploy CCash's WAR folder onto Tomcat:

  1. Compile your project by pushing the “GWT Compile Project” button in the google menu.
  2. Now deploy your war folder on Tomcat by copying it into your Tomcat/webapps
  3. :folder and renaming it “Ccash”. Tomcat should uncompress it and deploy it automatically.
nlp-private/ccash-setup.txt · Last modified: 2015/04/22 20:54 by ryancha
Back to top
CC Attribution-Share Alike 4.0 International
chimeric.de = chi`s home Valid CSS Driven by DokuWiki do yourself a favour and use a real browser - get firefox!! Recent changes RSS feed Valid XHTML 1.0